Author Archives: chury721

Migrace MikroTik RouterOS x86_64 z VMWare do Proxmoxu

Popisovat budu migraci ve formátu .OVA, což je univerzální formát, který lze zmigrovat na jiný (qcow2, vmdk, raw)

Je potřeba dostat soubor na server, SSHáčkem nebo třeba SCP.

  1. Nastavíme práva souboru:
    chmod 777 MikroTik_x86_64.ova
  2. Rozbalit na soubor MikroTik_x86_64-disk1.vmdk:
    tar -xvf MikroTik_x86_64.ova
  3. Převedeme na qcow2
    qm importdisk 123 MikroTik_x86_64.vmdk local-lvm -format qcow2
  4. Vytvoříme virtual v GUI Proxmoxu (https://adresa:8006), ostatní záložky si nastavíme dle vlastní potřeby:Po vytvoření HW vypadá takto, název „Hard Disku“ budeme potřeboval v dalším kroku:
  5. Nakopírujeme rozbalený qcow2 na místo vytvořeného v Proxmoxu:
    cp -rf MikroTik_x86_64.qcow2 /var/lib/vz/images/123/vm-123-disk-0.qcow
  6. Upravíme konfigurační soubor:
    nano /etc/pve/nodes/proxmox/qemu-server/123.conf
  7. K hodnotě Hard Disku (ide0) přidáme: ,model=VMware%20Virtual%20IDE%20Hard%20Drive,serial=00000000000000000001
    balloon: 512
     bootdisk: ide0
     cores: 1
     ide2: none
     localtime: 0
     memory: 2048
     name: MikroTIK
     numa: 0
     onboot: 1
     ostype: l26
     ide0: local:123/vm-123-disk-0.qcow2,cache=writethrough,model=VMware%20Virtual%20IDE%20Hard%20Drive,serial=00000000000000000001
     scsihw: virtio-scsi-pci
     smbios1: uuid=a2799fa4-97a3-fa45-f87c-977a8a2fb5d3
     sockets: 1
     vmgenid: 83df3129-ccc8-4a8a-ab84-a6d716d10d1b
  8. Spustíme virtual MikroTiku a můžeme používat:
    qm start 123

 

 

 

 

 

 

 

 

Auto upgrade MikroTik RouterOS & Firmware

  • Script pro automatický upgrade RouterOS a Firmware
  • Stačí vložit do Schelduleru
:local FWcurrent [/system routerboard get current-firmware]
:local FWupgrade [/system routerboard get upgrade-firmware]

### Pro upgrade ROS
/system package update
check-for-updates once
:delay 3s
:if ( [get status] = "New version is available") \
do={ \
:log info "Nova verze ROS je dostupna, stahuji..." 
install 
:log info "Restartuji..." 
} \
else={ \
:log info "Aktualni ROS, kontroluji Firmware..." 
### Pro upgrade Firmware
:if ($FWcurrent = $FWupgrade) \
      do={ \
      :log info "Aktualni Firmware" \
       } \
      else={ \
      :log info "Neaktualni Firmware" 
      :delay 2 
      :log info "Nastavuji upgrade" 
      /system routerboard upgrade
      :delay 10 
      :log info "Restartuji..."
      /system reboot
      } 
} 

Kompletní kod do terminálu pro vložení Schelduleru se spuštěním po startu s opakováním každý týden

/system scheduler
add interval=1w name="upgrade ROS" on-event=":local FWcurrent [/system routerboard get current-firmware]\r\
 \n:local FWupgrade [/system routerboard get upgrade-firmware]\r\
 \n### Pro upgrade ROS\r\
 \n/system package update\r\
 \ncheck-for-updates once\r\
 \n:delay 3s\r\
 \n:if ( [get status] = \"New version is available\") \\\r\
 \ndo={ \\\r\
 \n:log info \"Nova verze ROS je dostupna, stahuji...\" \r\
 \ninstall \r\
 \n:log info \"Restartuji...\" \r\
 \n} \\\r\
 \nelse={ \\\r\
 \n:log info \"Aktualni ROS, kontroluji aktualnost Firmware...\" \r\
 \n### Pro upgrade Firmware\r\
 \n:if (\$FWcurrent = \$FWupgrade) \\\r\
 \n do={ \\\r\
 \n :log info \"Aktualni Firmware\" \\\r\
 \n } \\\r\
 \n else={ \\\r\
 \n :log info \"Neaktualni Firmware\" \r\
 \n :delay 2 \r\
 \n :log info \"Nastavuji upgrade\" \r\
 \n /system routerboard upgrade\r\
 \n :delay 10 \r\
 \n :log info \"Restartuji...\"\r\
 \n /system reboot\r\
 \n } \r\
 \n} \r\
 \n" policy=reboot,read,write,policy,test,password,sensitive start-time=startup

MikroTik FIX: failed to pre-process ph2 packet

Chyba v logu:

17:15:06 ipsec,info respond new phase 1 (Identity Protection): 11.22.33.44[500]<= >123.123.123.123[500] 
17:15:07 ipsec,info ISAKMP-SA established 11.22.33.44[4500]-123.123.123.123[4500] s
pi:09fb1615031fff3f:1203czf470bd1f39 
17:15:07 ipsec,error 123.123.123.123 failed to pre-process ph2 packet.
17:15:11 ipsec,error 123.123.123.123 failed to pre-process ph2 packet.
17:15:14 ipsec,error 123.123.123.123 failed to pre-process ph2 packet.

Řešení je zvolit v „IP / IP sec / Policies / Group“ > default

Instalace oscamu do Octagon sf8008 4K s OpenATV

  1. Připojíme se do boxu pomocí ssh/Telnet jako uživatel root (IP adresu lze zjistit v nastavení připojení přes ovladač)
    • Dobré je změnit heslo roota příkazem:
    passwd
  2. Přepeneme se do složky tmp:
    cd /tmp
  3. Najdeme si nejnověší softcam-oscam balíček ve formátu ipk na webu: http://www.enigma2.net/category/enigma2/emu/oscam
  4. A stáhneme
    wget https://srv-store3.gofile.io/download/MUkO90/enigma2-softcams-oscam-all-images_11.686-emu-r798-arm%2Bmips_all.ipk
  5. Dále nainstalujeme přes obrazovku nebo OpenWebif snímek obrazovky (ip adresa boxu, port 80), na úvodní obrazovce zmáčkneme modré tlačítko a dostaneme se servisního menu.
    potvrdíme OK a nainstalujeme Oscam.
  6. Restartujeme box
    reboot
  7. Po restartu, v terminálu z editujeme oscam.conf:
    nano /etc/tuxbox/config/oscam.conf

    a vložíme:

    [global]
    logfile                       = /dev/tty
    preferlocalcards              = 2
    dropdups                      = 1
    
    [cache]
    max_time                      = 10
    
    [dvbapi]
    enabled                       = 1
    au                            = 1
    pmt_mode                      = 0
    user                          = dvbapiau
    boxtype                       = dreambox
    
    [webif]
    httpport                      = 83
    httphelplang                  = de
    httprefresh                   = 10
    httppollrefresh               = 10
    httphideidleclients           = 0
    httpshowmeminfo               = 1
    httpshowcacheexinfo           = 1
    http_status_log               = 1
    httpallowed                   = 10.0.0.0-10.255.255.255,172.16.0.0-172.31.255.255,192.168.0.0-192.168.255.255,127.0.0.1
    
  8. z editujeme oscam.server:
    nano /etc/tuxbox/config/oscam.server

    a vložíme:

    [reader]
    label                         = !!!nazev_serveru!!!
    protocol                      = cccam
    device                        = !!!DNS_nebo_IP_serveru!!!,12020
    user                          = !!!zadat_uzivatele!!!
    password                      = !!!zadat_heslo!!!
    inactivitytimeout             = 30
    group                         = 2
    lb_weight                     = 200
    cccversion                    = 2.1.1
    ccckeepalive                  = 1
    
    [reader]
    label                         = reader0
    protocol                      = internal
    device                        = /dev/sci0
    caid                          = 0624
    detect                        = cd
    mhz                           = 500
    group                         = 1
    emmcache                      = 1,3,2,0
    
  9. Provedeme restart
    reboot
  10. V Nastavení Oscamu je potřeba zvolit námi nastavený Oscam kliknutím doprava.

    • hotovo


    • Status Oscamu lze zkontroloval doinstalováním pluginu „Oscam-status“ nebo na ip adrese boxu s portem 83

BootCamp s Windows 7 – chyba instalace

Při instalaci Windows 7, přes BootCamp se vyskytl problém po zadání základních přihlašovacích údajů o uživateli a systém již nešel spustit po vypsání této chyby: „Proces inicializace interaktivního přihlášení se nezdařil“ (tato chyba se zobrazila pouze 1s, skoro nepostřehnutelné)

Řešením je vložit instalační USB flashdisk s Win7 a proklikat se do opravy systemu a dále do příkazového řádku, kde je potřeba postupně spustit tyto příkazy:

  1. bootrec /RebuildBcd
  2. bootrec /FixMbr
  3. bootrec /Fixboot

Po té provést restart a dát boot s Windows oddílu.

 

Konfigurace HW: MacBook Air mid2011, macOS High Sierra

Cyberpunk 2077 nastavení češtiny Steam

  • Návod je určen pro ty, kteří mají hru nainstalovanou přes Steam.
  • Čeština se ve hře nastaví (menu a titulky), ale po restartu hry je vše opět v základním nastavení. Důvodem proč se toto děje, je launcher Steamu, který v sobě pro hru nemá implementovanou češtinu. Při každém spuštění launcher přepíše hodnoty ve hře na English.
  • Řešením je přeskočit launcher a spustit hru napřímo
  • Vytvoříme na ploše ikonu s odkazem (pokud máme nainstalovanou hru defaultně, jinak je potřeba cesta individuálně upravit):
    „C:\Program Files (x86)\Steam\steamapps\common\Cyberpunk 2077\bin\x64\Cyberpunk2077.exe“ nebo stáhněte zip a rozbalte:
    Cyberpunk2077.lnk:
  • Hru spustíme, nastavíme jazyk a při příštím spuštění už vše zůstává.

Category: Hry

Error: Failed to launch the browser process! spawn chrome.exe ENOENT

Chyba: Error: Failed to launch the browser process! spawn chrome.exe ENOENT

Řešení je zadat úplnou cestu k aplikaci google-chrome (‚/usr/bin/google-chrome‚).

const browser = await puppeteer.lauch({
executablePath: '/usr/bin/google-chrome',
headless: true,
args: ['--no-sandbox', '--disable-setuid-sandbox'],
})

VCDS – Kodování Škoda Octavia III (5E)


Denní svícení pomocí mlhových světel:

Pokud je to az v 30 Bytu:
E5888F0700041A00470A00000F00000000095D435C00012C000000000000

Panické brždění

Při prudkém brždění dojde k blikání brzdových světel. A ke spuštění výstražných světel.

Jednotka: 09-Centrální elektrika, kódování-07 kód vložit do LCode, v bytu 17 zaškrtnout bit 0

Zadní světla spolu s denním svícením

pouze krajní dvě žárovky, s tlumenýma světlama se rozsvítí zbytek lampy a RZ.
Pro rok výroby 2016
Jednotka: 09-Centrální elektrika, 16-Secure access 31347 zadat, 10-Adaptation:
– (6 ) DRL Tagfahrlicht Dauerfahrlicht aktiviert zusätzlich standlicht nastavit na Active
– (x) Leuchte23SL HLC10 Lichtfunktion D – 23 nastavit na Daytime running lights (Tagfahrlicht)
– (x) Leuchte24SL HRA65 Lichtfunktion D – 24 nastavit na Daytime running lights (Tagfahrlicht)
Hodnota x se liší v závislosti na konfiguraci světel – pro halogeny nebo Bi-Xenonové světlomety
Pro rok výroby 2014
Jednotka: 09-Centrální elektrika, 16-Secure access 31347 zadat, 10-Adaptation:
– (x) Leuchte23SL HLC10 Lichtfunktion D – 23 nastavit na Daytime running lights (Tagfahrlicht)
– (x) Leuchte24SL HRA65 Lichtfunktion D – 24 nastavit na Daytime running lights (Tagfahrlicht)


Sklopení pravého zpětného zrcátka při couvání

Jednotka: 52, v coded byte 4 bit 2 a bit 3 je on
Unit 09 , 16-Secure access 31347 zadat, 10-Adaptation:
– (15) Access Control 2- Spiegelabsenkung nastavit na Active
– (20) Access Control 2- Menusteuerung spiegelabsenkung nastavit na  Active

Asistent rozjezdu do kopce (HHC)

Jednotka 03-ABS, Byte 25, bit 0 a 1
Přes LCode 2 (je v nabídce LCode nahoře), tam zaškrtnut.

Nastavení HHC

1. STG 03 (Bremsenelektronik) auswählen
2. STG Anpassung -> Funktion 10
3. Berganfahrassistent (Hill-start assistant)
4. wert entsprechend anpassen
(Default Wert: normal) LATE => drží déle brzdu

Popř aktivace elektronické uzávěrky diferenciálu (XDS) – jednotka ABS, Byte 23, bit 1

Komfort

Dotažení nezavřených oken bez nutnosti držení ovladače do konce

Zmáčkout zamčení a počkat cca 3s než se okna začnou zavírat, potom se již automaticky zavřou. Funguje taky pro střešní okno.

Kódování: 46-Komfort systém, kódování-07 kód vložit LCode, v bytu 6 zaškrtnout bit 6

Synchronní nastavení zrcátek

Kódování: 46-Komfort systém, kódování-07 kód vložit do LCode, v bytu 14 zaškrtnout bit 6

Odpojení příhřevu (Webasto) – Citroën Evasion / Peugeot 806 / Fiat Ulysse / Lancia Zeta

Neustále mne štvalo, že se mi příhřev (dále jen Webasto) zn. Webasto Thermo Top Z/C-D ve vozidle Citroën Evasion 2.0HDi, spíná do cca 12C nebo když jedu jen krátkou vzdálenost, tak po vypnutí motoru docela dlouho Webasto dobíhá. Nemám tedy do běhu Webasta jak zasáhnou/přizpůsobit si ho (v ECU lze změnit pásmo provozu, což sníží spínání jen o pár stupňů)

Řešeních je více:

  1. Dokoupit kabeláž a tím udělat z příhřevu opravdu nezávislé topení (nutno předělat hadice v motoru a dodělat aktivaci vnitřního ventilatoru). Lze pak spínat čudlikem, hodinkama nebo třeba dálkovým ovladačem. Investice za kabeláž kolem 2000,-Kč
  2. Odpojováním napájení Webasta, scartka s dvoumi tlustými kabely (+/-). Vždy s vypnutým motorem, v opačné připadě motor chcípne a zapíše se závada do ECU.
  3. Čudlíkem odpojovat čidlo teploty (termistor).

Já si udělal možnost č.3. Lze zapínat i za běhu motoru.